Home » Community » Message Boards » Total Beauty Member Central » Site issues

Discussion

evet
allstar
1 year, 1 month ago
Site issues

I had tried to send a message via contact form, and now there is a captcha request with no visuals except the words Captcha image.  The actual problem was the survey for the Nexus product, and the questions indicated you should be able to have more than one answer.  If that was valid for you, the survey only allowed you one choice.  I was not able to insert a comment, so other people will have the same problem. 

 Reply
Subscribe
Notifiy me with emails too



2 Replies

KimTB
newbie
1 year, 1 month ago
Re: Site issues

Hi Evet! Sorry you're having problems with the site and the survey. In order to address the problem we need to know what Internet browser you are using. In the mean time, I'll forward your issue along. -Kim


evet
allstar
1 year, 1 month ago
Re: Re: Site issues
KimTB posted:

Hi Evet! Sorry you're having problems with the site and the survey. In order to address the problem we need to know what Internet browser you are using. In the mean time, I'll forward your issue along. -Kim

I borrow this computer which is a Mac and I am using Firefox. I can also view on Firefox on an HP. I have the option of checking on various browsers if necessary.


Welcome to TotalBeauty.com!
Ready to unleash your inner beauty junkie? Enter your email and check the boxes below to get free samples, exclusive deals, discounts at Total Beauty Shops, and expert beauty tips delivered straight to your inbox!
Email to a friend